Cloudflare System Status

Increased HTTP 502 Errors in Hong Kong region

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 13, 2026 - 15:08 UTC

Investigating

Cloudflare is investigating an increased level of HTTP 502 errors impacting customers in Hong Kong region
Posted May 13, 2026 - 14:49 UTC
This incident affected: Cloudflare Sites and Services (Network).