Last updated: Fetched just now
MSP (Minneapolis) on 2022-10-28
Started
Completed
Timeline
- Completed
The scheduled maintenance has been completed.
- In Progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
- Updated
Maintenance will begin as scheduled in 60 minutes.
- Scheduled
We will be performing scheduled maintenance in MSP (Minneapolis) datacenter on 2022-10-28 between 08:00 and 13:00 UTC. Traffic might be re-routed from this location, hence there is a possibility of a slight increase in latency during this maintenance window for end-users in the affected region.