Cloudflare System Status

Cloudflare is investigating issues with network performance in DEL.

Incident Report for Cloudflare

Resolved

We applied an effective fix for this issue. This incident is now resolved.
Posted May 22, 2025 - 22:29 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted May 22, 2025 - 07:54 UTC

Investigating

We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted May 21, 2025 - 21:51 UTC
This incident affected: Asia (New Delhi, India - (DEL)).