Cloudflare System Status

Load Balancing health monitoring impacted

Incident Report for Cloudflare

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 30, 2026 - 22:49 UTC

Investigating

Cloudflare is currently investigating issues with its Load Balancing Health Monitoring services. During this time there may be a delay in responding to endpoint health changes.
Posted Apr 30, 2026 - 22:31 UTC
This incident affects: Cloudflare Sites and Services (Load Balancing and Monitoring).