Cloudflare System Status

Internal Server Error when subscribing to Workers or Argo

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 10:48 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 17, 2025 - 10:12 UTC

Update

We are continuing to investigate this issue.
Posted Jun 17, 2025 - 10:04 UTC

Investigating

Some customers were getting an Internal Server Error (Error 1000) when trying to subscribe to Workers or Argo plans.

Impact was observed between 6/6 and 6/16.

We're currently investigating this issue.
Posted Jun 06, 2025 - 00:00 UTC
This incident affected: Cloudflare Sites and Services (Billing, Stream, Workers).