Cloudflare System Status

Cloudflare for Teams: unable to complete purchases
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 23, 2021 - 22:32 UTC
Investigating
Cloudflare is investigating an issue that prevents access to completing purchases within the Cloudflare for Teams dashboard.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 23, 2021 - 21:37 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Teams Dashboard).