Cloudflare System Status

Cloudflare Access dashboard shows duplicates when editing applications
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 14, 2022 - 20:27 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted May 14, 2022 - 19:01 UTC
Investigating
Cloudflare is investigating an issue where editing an Access application can cause duplicates to appear in the UI.
Posted May 14, 2022 - 18:43 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Zero Trust Dashboard).