Cloudflare System Status

Area 1 Horizon is down
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 11, 2024 - 19:51 UTC
Identified
The cause of this issue has been identified and a fix is being implemented.
Posted Apr 11, 2024 - 19:33 UTC
Investigating
Area 1 Horizon is currently experiencing an outage. Engineers are currently investigating.
Posted Apr 11, 2024 - 19:32 UTC