Cloudflare System Status

Users in South Africa and the APAC region may experience high latency and connection timeouts
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 17, 2021 - 05:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 17, 2021 - 05:38 UTC
Investigating
Cloudflare is observing network congestion resulting in Slow connections, timeouts, and failures for Datacenters in APAC and South Africa.
Posted Apr 17, 2021 - 05:30 UTC