Cloudflare System Status

Large DNS attack in multiple DCs
Incident Report for Cloudflare
Resolved
The attack has been mitigated.
Posted Mar 18, 2015 - 07:10 UTC
Identified
There is a large DNS attack ongoing across many datacenters, mostly in the US. Updates shortly.
Posted Mar 18, 2015 - 06:56 UTC