Cloudflare System Status

Issues with Cloudflare Images and Image Resizing
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jan 12, 2024 - 21:51 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 12, 2024 - 21:37 UTC
Update
The issue was identified in png decoder. The code fix was rolled out globally. The rollout to purge corrupted images from cache is in progress.
Posted Jan 12, 2024 - 19:08 UTC
Identified
The issue was identified in png decoder. The code fix was rolled out globally. The rollout to purge corrupted images from cache is in progress.
Posted Jan 12, 2024 - 13:57 UTC
Investigating
Cloudflare is investigating issues with corrupted images returned by Cloudflare Images and Image Resizing products for some customers. We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jan 12, 2024 - 13:31 UTC
This incident affected: Cloudflare Sites and Services (Image Resizing, Images).