Cloudflare System Status

Secrets Loss When Changing the Usage Model Flag for Workers
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Apr 21, 2022 - 17:16 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2022 - 16:54 UTC
Update
Workers customers are currently unable to change their Usage Model in Terraform, Wrangler, UI, or API while an update is applied to those endpoints. We have identified the root cause and are applying the fix.
Posted Apr 21, 2022 - 15:55 UTC
Identified
Workers customers adjusting their Usage Model in the UI or API may experience loss of environment variables or secrets. We have identified the root cause and are applying the fix. It's recommended customers avoid changing their Usage Model until this is resolved.
Posted Apr 21, 2022 - 15:30 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Workers).