Cloudflare System Status

Cloudflare Access experiencing delays with Access app creation and updates

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Mar 18, 2026 - 03:51 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 18, 2026 - 02:24 UTC

Investigating

Cloudflare is investigating an issue causing configuration changes for creating, updating, and removing Access applications to be delayed.

Existing Access applications are not impacted and access will continue to work as intended.
Posted Mar 18, 2026 - 02:19 UTC
This incident affected: Cloudflare Sites and Services (Access).