Cloudflare System Status

Cloudflare Pages Build Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 15, 2021 - 15:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 15, 2021 - 14:07 UTC
Update
We are continuing to investigate this issue and will provide further updates shortly.
Posted Jun 15, 2021 - 13:16 UTC
Investigating
Cloudflare is investigating issues with Cloudflare Pages build delays. This issue does not affect any other Cloudflare services.

We are working to mitigate this problem. More updates to follow shortly.
Posted Jun 15, 2021 - 10:52 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Pages).