Cloudflare System Status

Network Performance Issues in Phoenix, AZ

Incident Report for Cloudflare

Resolved

This was resolved at 19:52UTC
Posted Jun 30, 2026 - 23:14 UTC

Investigating

Cloudflare is investigating network performance issues in the Phoenix, AZ region. Users may experience slow requests or increased latency. We are actively analyzing the issue and working on mitigation.

Updates will be provided as more information becomes available.
Posted Jun 30, 2026 - 19:15 UTC
This incident affected: North America (Phoenix, AZ, United States - (PHX)).