Minor ImpactLast updated: Fetched just now
Cache Purging Delays
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Investigating
Cloudflare cache purging called via the Dashboard/API is currently experiencing some latency. We are working to resolve this issue as soon as possible. More updates to follow.