Cloudflare System Status

Accidental "major incident" notification

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 12:52 UTC

Monitoring

We understand how concerning it must have been to receive an unexpected email about a major incident. The message you may have received was sent in error. During a routine internal drill, a test notification was inadvertently distributed externally.

Please rest assured there is no active major issue impacting Cloudflare services — everything is operating normally.

We’re truly sorry for any confusion or worry this may have caused you or your team. No action is needed on your side, and you can safely disregard that email. For the most accurate and up-to-date information at any time, please refer to our Cloudflare Status Page (https://www.cloudflarestatus.com/).

Thank you for your understanding, and for trusting Cloudflare.
Posted Aug 20, 2025 - 12:09 UTC
This incident affected: Cloudflare Sites and Services (Dashboard).