Cloudflare System Status

Dashboard Login Latency and Timeouts

Incident Report for Cloudflare

Update

As part of this issue, from 20:37 to 20:40 UTC some customers would have experienced elevated rates of HTTP 522 error responses for requests originating in Europe. We are continuing to monitor the effectiveness of our fix.
Posted Dec 03, 2025 - 21:55 UTC

Monitoring

We have identified the cause of this issue and implemented a fix. We are currently monitoring the results.
Posted Dec 03, 2025 - 21:45 UTC

Investigating

We are investigating an issue with elevated dashboard login latency and timeouts for European users.
Posted Dec 03, 2025 - 21:13 UTC
This incident affects: Cloudflare Sites and Services (Dashboard).