Cloudflare System Status

proxy_read_timeout endpoint and maximum upload size return 400 error

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jun 19, 2025 - 03:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 19, 2025 - 03:24 UTC

Investigating

Cloudflare has identified an issue where our proxy_read_timeout endpoint and maximum upload size return 400 error. We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 19, 2025 - 02:44 UTC
This incident affected: Cloudflare Sites and Services (API).