Cloudflare System Status

Cloudflare lists API delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Jul 18, 2025 - 09:48 UTC

Monitoring

We have identified the cause for this issue and applied a fix. We are currently monitoring the results.
Posted Jul 17, 2025 - 17:48 UTC

Investigating

Cloudflare is investigating issues with the API for URL lists, bulk redirect lists and hostname lists.

Customers using the dashboard or Cloudflare APIs may find that their changes have a significant delay before taking effect at the Cloudflare Edge.

These issues do not affect the serving of cached files via the Cloudflare CDN or other security features at the Cloudflare Edge.
Posted Jul 17, 2025 - 15:43 UTC
This incident affected: Cloudflare Sites and Services (Lists).