Cloudflare System Status

Cloudflare Registrar unable to process operations for Identity Digital TLD domains
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Jun 20, 2023 - 15:31 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 20, 2023 - 15:16 UTC
Investigating
Cloudflare is investigating issues with its Registrar services that impact some customers with Identity Digital TLD domains for new registrations, transfers and renewals operations.

See https://www.cloudflare.com/tld-policies/ for the list of Identity Digital TLDs.

Registration services for other TLDs are not impacted.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 20, 2023 - 14:54 UTC
This incident affected: Cloudflare Sites and Services (Registrar).