Cloudflare System Status

Network Performance Issues in Amsterdam

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Dec 28, 2024 - 20:41 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 28, 2024 - 18:44 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Dec 28, 2024 - 16:33 UTC

Investigating

Cloudflare is investigating issues with Network Performance in Amsterdam region from 14:30 UTC today.

We are working to analyze and mitigate this problem. More updates to follow shortly.
Posted Dec 28, 2024 - 16:11 UTC
This incident affected: Europe (Amsterdam, Netherlands - (AMS)).