Cloudflare System Status

Issue with Keyless SSL

Incident Report for Cloudflare

Resolved

This issue has been resolved.
Posted Dec 13, 2017 - 04:04 UTC

Monitoring

We have implemented a fix for this issue and are currently monitoring the results. We will update once we have confirmed it is resolved.
Posted Dec 13, 2017 - 04:00 UTC

Investigating

Customers who have enabled Geo Key Manager for their custom certificate(s) may be unable to connect to their domain using HTTPS from Cloudflare data centers other than those specified by Geo Key Manager.
Posted Dec 13, 2017 - 01:32 UTC