Cloudflare System Status

Billing Service Maintenance
Incident Report for Cloudflare
Resolved
The maintenance has been completed and Billing Service has returned to normal.
Posted Oct 12, 2017 - 21:39 UTC
Investigating
We are performing maintenance on our subscription services on October 12th starting at 2:20 PM PDT. For approximately 15 minutes you may see a delay in processing changes to subscriptions. All other services are operating normally. We will post an update once the maintenance is complete.
Posted Oct 12, 2017 - 21:20 UTC
This incident affected: Cloudflare Sites and Services (Billing).