Cloudflare System Status

DNS update propagation temporarily delayed
Incident Report for Cloudflare
Resolved
DNS propagation has returned to normal.
Posted Apr 22, 2015 - 00:16 UTC
Investigating
We are investigating a problem with DNS propagation of any records updated since approximately 21:00 UTC.
Posted Apr 21, 2015 - 21:30 UTC