Cloudflare System Status

Global Issues with 1.1.1.1 public resolver

Incident Report for Cloudflare

Resolved

A recent software update inadvertently altered the ordering of DNS records within our cached responses. Specifically, the sequence of CNAME and non-CNAME records in the "answer" section was changed, which conflicted with the expectations of certain DNS client implementations. Upon identifying this behavior, we reverted the release to restore standard record ordering and resolve connectivity issues for affected users.
Posted Jan 08, 2026 - 20:25 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 08, 2026 - 20:01 UTC

Identified

Cloudflare is aware of, and investigating, an issue which potentially impacts users globally that use 1.1.1.1 public resolver. Further detail will be provided as more information becomes available.
Posted Jan 08, 2026 - 18:51 UTC