Cloudflare System Status

Some Workers requests may be serving an incorrect 404 page

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 01, 2025 - 18:39 UTC

Identified

Workers are serving an incorrect 404 page. The team is working on a fix.
Posted May 01, 2025 - 18:30 UTC
This incident affected: Cloudflare Sites and Services (Workers).