Cloudflare System Status

Network Connectivity Issues in Ashburn Virginia Area.

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 04:36 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 04:03 UTC

Investigating

Cloudflare is investigating issues with network connectivity in the Ashburn Virginia area.
Posted Apr 23, 2026 - 03:57 UTC
This incident affected: North America (Ashburn, VA, United States - (IAD)).