Cloudflare System Status

Load Balancing Performance Degradation
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 04, 2020 - 20:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 04, 2020 - 19:51 UTC
Investigating
We are observing issues impacting Load Balancing event analytics, email notifications, and steering for regional pools.

We are working on mitigating these issues. More updates to follow.
Posted Mar 04, 2020 - 19:35 UTC
This incident affected: Cloudflare Sites and Services (Load Balancing and Monitoring).