A fix has been implemented and we are monitoring the results.
Posted Jul 30, 2026 - 14:23 UTC
Investigating
We are investigating an issue where Page Shield email notifications are not containing the correct data for some customers. Our engineering team is currently working on a fix to restore accurate alert delivery. We will provide updates as soon as more information is available.
Posted Jul 30, 2026 - 13:16 UTC
This incident affected: Cloudflare Sites and Services (Notifications, Page Shield).