The issue has been identified and a fix is being implemented.
Posted Aug 04, 2026 - 02:30 UTC
Investigating
Cloudflare is aware that deploying Workers that the nodejs_compat compatibility flag and a compatibility date on or after 2026-08-04 is being disallowed. This is impacting Workers and Workers for Platforms.
We are working on relaxing this assertion. To avoid this error, remove the nodejs_compat compatibility flag from your Worker.
Posted Aug 04, 2026 - 01:56 UTC
This incident affected: Cloudflare Sites and Services (Workers).