Cloudflare System Status

Cloudflare Access AI control - MCP server creation impacted

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 19, 2026 - 23:37 UTC

Update

We are continuing to investigate this issue.
Posted May 19, 2026 - 22:09 UTC

Investigating

Customers may experience issue adding new MCP Servers or authenticating existing ones through the Zero Trust Dash
Posted May 19, 2026 - 21:59 UTC
This incident affected: Cloudflare Sites and Services (MCP Portal).