Cloudflare System Status

Network Performance Issues in Buenos Aires, Argentina
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Mar 18, 2021 - 16:12 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 18, 2021 - 13:54 UTC
Monitoring
Cloudflare is investigating issues with network performance in Buenos Aires, Argentina.
We are have mitigated this problem and are investigating the underlying issues.
Posted Mar 18, 2021 - 13:45 UTC
This incident affected: Latin America & the Caribbean (Buenos Aires, Argentina - (EZE)).