Minor ImpactLast updated: Refreshed just now
Network Performance Issues
Started
Resolved
Timeline
- Resolved
This incident has been resolved.
- Monitoring
Cloudflare has identified issues with Network Performance in some locations. We have applied mitigations to address this problem and are monitoring to observe their effectiveness. More updates to follow shortly.