Cloudflare System Status

Certificate Transparency Log
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Dec 17, 2023 - 01:08 UTC
Investigating
There are numerous reports on duplicated notifications for SSL renewals.
Posted Dec 17, 2023 - 00:06 UTC
This incident affected: Cloudflare Sites and Services (Notifications).