Cloudflare System Status

DNS Queries Issue
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted May 19, 2021 - 01:54 UTC
Update
We are in the process of rolling out a fix and will provide an update once completed.
Posted May 18, 2021 - 22:38 UTC
Identified
The issue has been identified, and a fix is being implemented.
Posted May 18, 2021 - 21:31 UTC
Investigating
Cloudflare is investigating issues that may impact some DNS queries. We are currently working on a resolution and will provide an update as soon as possible.
Posted May 18, 2021 - 21:24 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Authoritative DNS).