Cloudflare System Status

Workers Deployment Delays

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 18, 2023 - 00:32 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 18, 2023 - 00:07 UTC

Investigating

Cloudflare is experiencing delays in updating Workers on the edge and executing new Cloudflare Pages deployments. This does not impact existing Workers and Pages projects already deployed in production.
Posted May 17, 2023 - 21:14 UTC