Cloudflare System Status

R2 and Teams' payments failing during Checkout flow

Incident Report for Cloudflare

Update

We are continuing to work on a fix for this issue.
Posted Jun 08, 2026 - 10:06 UTC

Identified

Starting June 5, 2026 (~12:00 UTC), users adding R2 and Teams products see "An unexpected error occurred while processing your payment." blocking them from creating subscriptions.
Posted Jun 08, 2026 - 10:05 UTC
This incident affects: Cloudflare Sites and Services (Billing, R2, Zero Trust).