Cloudflare System Status

Email Delivery Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 03:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2022 - 03:09 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 14, 2022 - 02:58 UTC
Investigating
Cloudflare is investigating a delay in our ability to send emails. This includes password reset, mFA token emails. We are working to resolve the issue. More updates to follow shortly.
Posted Nov 14, 2022 - 02:40 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Dashboard).