Cloudflare System Status

Network Performance Issues in Seattle
Incident Report for Cloudflare
Resolved
This issue has been resolved.
Posted Oct 13, 2016 - 03:44 UTC
Investigating
Cloudflare is observing network performance issues in Seattle. We are actively working to reduce or eliminate any impact to Internet users in this region.
Posted Oct 13, 2016 - 03:08 UTC
This incident affected: North America (Seattle, WA, United States - (SEA)).