Cloudflare System Status

Issues with submitting Abuse Reports
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted Feb 26, 2024 - 15:54 UTC
Update
We are continuing to investigate this issue.
Posted Feb 26, 2024 - 13:25 UTC
Investigating
Cloudflare is aware of, and investigating an issue which impacts the submission of abuse reports. Further detail will be provided as more information becomes available.
Posted Feb 26, 2024 - 13:24 UTC
This incident affected: Cloudflare Sites and Services (Abuse Reports).