Cloudflare System Status

Possible Network Congestion in North America
Incident Report for Cloudflare
Resolved
We have investigated & confirmed there was no customer impact so we are closing this incident
Posted Aug 21, 2020 - 14:08 UTC
Investigating
Cloudflare is observing possible network congestion in North America.

We are working to mitigate impact to Internet users in this region.
Posted Aug 21, 2020 - 14:04 UTC
This incident affected: North America (Chicago, IL, United States - (ORD)).