Cloudflare System Status

Spectrum Availability issues
Incident Report for Cloudflare
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.
Posted Jun 05, 2020 - 17:06 UTC
Monitoring
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Jun 05, 2020 - 16:48 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Jun 05, 2020 - 15:48 UTC
Investigating
Cloudflare is investigating issues with Spectrum. This may be impacting the availability of existing Spectrum applications.

We are working to understand the full impact and mitigate this problem. More updates to follow shortly.
Posted Jun 05, 2020 - 15:16 UTC
This incident affected: Cloudflare Sites and Services (Cloudflare Spectrum).