Cloudflare System Status

Increased Error Response Rate in R2 Storage Service

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted May 29, 2025 - 17:54 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2025 - 17:50 UTC

Identified

Clients using Cloudflare's R2 Storage service in Europe may experience elevated error response rates on write operations. Impacted customers would see HTTP 429 responses on affected operations. We have identified the issue and are implementing mitigations.
Posted May 29, 2025 - 17:14 UTC
This incident affected: Cloudflare Sites and Services (R2).