Cloudflare System Status

Zero Trust Posture failure

Incident Report for Cloudflare

Resolved

Every impacted device has now self-healed. This incident has been resolved.
Posted Jul 23, 2025 - 03:52 UTC

Update

A fix has been implemented and we are monitoring the results.
Posted Jul 23, 2025 - 03:04 UTC

Monitoring

WARP Devices that were rebooted, registered, or rotated keys between July 22 2025 17:25 UTC and July 22 2025 20:00pm are impacted by this incident. Impacted customers can manually reboot their WARP Devices, or rotate keys, to recover. If no action is taken, WARP Devices will automatically self-heal within 24 hours.
Posted Jul 22, 2025 - 20:12 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Jul 22, 2025 - 20:06 UTC

Investigating

Some WARP Devices may be failing to report posture status.
Posted Jul 22, 2025 - 19:51 UTC
This incident affected: Cloudflare Sites and Services (WARP).