Cloudflare System Status

DNS Update Delays
Incident Report for Cloudflare
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 04, 2019 - 15:53 UTC
Update
DNS update delays are recovering with a maximum delay of 30 minutes. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 15:11 UTC
Update
DNS update delays are recovering with a maximum delay of 45 minutes. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 14:46 UTC
Update
DNS update delays are recovering with a maximum delay of 1 Hour and 5 minutes. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 14:17 UTC
Update
We are continuing to monitor for any further issues.
Posted 5 months ago. Jun 04, 2019 - 14:17 UTC
Monitoring
DNS update delays are recovering with a maximum delay of 1 Hour and 20 minutes. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 13:55 UTC
Update
DNS update delays are recovering with a maximum delay of 1 Hour and 45 minutes. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 13:18 UTC
Identified
DNS update delays are recovering with a maximum delay of 2 hours. We will continue to update as the Incident progresses.
Posted 5 months ago. Jun 04, 2019 - 12:45 UTC
Update
Cloudflare is investigating delays by over two Hours in updates to DNS records. These delays only affect record changes and updates.
Posted 5 months ago. Jun 04, 2019 - 12:14 UTC
Update
Cloudflare is investigating delays by over one Hour in updates to DNS records. These delays only affect record changes and updates.
Posted 5 months ago. Jun 04, 2019 - 11:23 UTC
Update
Cloudflare is investigating delays by over one Hour in updates to DNS records. These delays only affect record changes and updates.
Posted 5 months ago. Jun 04, 2019 - 10:47 UTC
Update
Creating or reconnecting Argo Tunnels takes over 15 minutes due to DNS replication lag. Existing active tunnels are operational.
Posted 5 months ago. Jun 04, 2019 - 09:17 UTC
Investigating
Cloudflare is investigating delays by over 15 minutes in updates to DNS records. These delays only affect record changes and updates.

DNS resolution is operating normally.
Posted 5 months ago. Jun 04, 2019 - 08:17 UTC
This incident affected: Cloudflare Sites and Services (Argo Tunnel, DNS Updates).