Cloudflare System Status

Cloudflare Pages: Compression issues with custom hostnames

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 01, 2025 - 08:51 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 01, 2025 - 08:38 UTC

Identified

Cloudflare has identified an issue with our Pages feature: Customers under our Free plan using custom hostnames may experience specific pages unexpectedly returning zstd compression mode. Customers experiencing this issue can add a compression rule to enforce brotli or gzip compression to temporarily circumvent the problem. Nevertheless, we are working to mitigate this issue, more updates to follow shortly.
Posted Jul 31, 2025 - 14:15 UTC
This incident affected: Cloudflare Sites and Services (Pages).