Cloudflare System Status

Free, Pro, and Biz Tiered Cache degradation

Incident Report for Cloudflare

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 00:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Aug 20, 2025 - 23:57 UTC

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 20, 2025 - 22:39 UTC

Investigating

Free, Pro, and Biz Customers origins are experiencing Tiered Cache degradation where Tiered Cache is not engaging as expected. This results in more cache misses and increased requests to the origin.
Posted Aug 20, 2025 - 19:40 UTC
This incident affected: Cloudflare Sites and Services (CDN/Cache).