Cloudflare System Status

Email Routing - Increased deliverability issues to outlook.com

Incident Report for Cloudflare

Resolved

Deliverability to outlook.com is at normal levels.
Posted Sep 21, 2024 - 23:58 UTC

Monitoring

This issue was mitigated and deliverability to outlook.com is improving. We are monitoring.
Posted Sep 21, 2024 - 22:57 UTC

Investigating

We are currently investigating this issue.
Posted Sep 21, 2024 - 21:01 UTC
This incident affected: Cloudflare Sites and Services (Email Routing).