Cloudflare System Status

Network Performance Issues in Frankfurt

Incident Report for Cloudflare

Resolved

This incident has been canceled: no actual impact was observed, and network performance remained at nominal levels.
Posted Oct 21, 2025 - 13:42 UTC

Investigating

Cloudflare is investigating issues with network performance in Frankfurt. We are working to analyse and mitigate this problem. More updates to follow shortly.
Posted Oct 21, 2025 - 12:47 UTC
This incident affected: Cloudflare Sites and Services (Network).